University of Tartu IT services status page - Overleaf is not working – Incident details
Get updates
Email
Microsoft Teams
Webhook
RSS
Atom
API
Get updates
Dark mode
Language
All systems operational
Overleaf is not working
Resolved
Major outage
Started 10 months ago
27th October 2025
Lasted 2 minutes
27th October 2025
21:20
21:22
UTC
Affected
Overleaf
Operational from 9:20 PM to 9:22 PM
Overleaf
Major outage from 9:20 PM to 9:22 PM
Updates
Resolved
27th October 2025 at 21:22
UTC
Resolved
27th October 2025 at 21:22
UTC
Overleaf work has been restored (automatic notification).
Investigating
27th October 2025 at 21:20
UTC
Investigating
27th October 2025 at 21:20
UTC
Overleaf is currently unavailable (automatic notification).
UTC
UTC
UTC
UTC
UTC