University of Tartu IT services status page - Errors when using ID-card in Firefox ver. 141.0 web browser – Incident details
All systems operational
Errors when using ID-card in Firefox ver. 141.0 web browser
Resolved
Degraded performance
Started 3 months agoLasted about 2 months
Affected
ID card
Degraded performance from 10:02 AM to 12:13 PM
Updates
Resolved
Resolved
Firefox version 143.0 ID card login works
Investigating
Investigating
From July 30th there are errors when using the ID card with the latest version of Firefox, mobile-ID and smart-ID work. Alternatively, you can use the MS Edge or Google Chrome web browser to work with the ID card.