University of Tartu IT services status page - Mobile communication failures from September 5 at 11:50 – Incident details

All systems operational

Mobile communication failures from September 5 at 11:50

Resolved
Major outage
Started 11 days agoLasted 34 minutes

Affected

Other services

Major outage from 8:55 AM to 9:30 AM

Updates
  • Resolved
    Update

    Official answer: Today between 11 and 12:30, Telia's voice communication services were disrupted because our network suffered a major failure. A thorough investigation has been initiated to prevent similar incidents in the future.

  • Resolved
    Resolved

    The service has been restored.

  • Investigating
    Update

    This is a general failure of UT's communication partner Telia.

  • Investigating
    Investigating

    From September 5th at 11:50 there are problems with mobile communications. We are working on solving the problem.